• Croquette@sh.itjust.works
      link
      fedilink
      arrow-up
      0
      ·
      4 months ago

      I tend to add is to booleans toreally differentiate between a method name and a status.

      def open_file_dialog(self):
          self.dialog_file_is_open = True
          pass
      

      That way, it’s easier for my dumb brain to spot which is which at a glance.

      • 4wd@programming.dev
        link
        fedilink
        arrow-up
        0
        ·
        4 months ago

        In Elixir, we mark statuses by using a question mark at the end of the variable name. Something like this:

        authorized? = user |> get_something() |> ensure_authorized?()
        

        I like this better than the is_ prefix

          • FMT99@lemmy.world
            link
            fedilink
            arrow-up
            0
            ·
            4 months ago

            We do this in Ruby all the time, we just prefer methods over variables, usually.

            def authorized?
              current_user&.authorized?
            end
            
            • cytokine0724@sh.itjust.works
              link
              fedilink
              arrow-up
              0
              ·
              4 months ago

              I’m a principal backend engineer routinely writing Ruby for my day job, so I’m familiar, lol. But you can’t do it for local variables and that just sucks. Definitely a +1 for Elixir.

          • Faresh@lemmy.ml
            link
            fedilink
            English
            arrow-up
            0
            ·
            4 months ago

            If it’s like Lisp, then ? is just part of the symbol and doesn’t have any special syntatic meaning. In different Lisps it’s also convention to end predicate names with a ? or with P (p for predicate)

          • sus@programming.dev
            link
            fedilink
            arrow-up
            0
            ·
            edit-2
            4 months ago

            that works for 2 word names eg is_open or is_file, but in this case is_dialog_file_open is structured like a question, while dialog_file_is_open is structured like a statement

            • Rinox@feddit.it
              link
              fedilink
              arrow-up
              0
              ·
              4 months ago

              Doesn’t matter, the point is that, if it starts with “is” then you automatically know it’s a boolean.

            • redfellow@sopuli.xyz
              link
              fedilink
              arrow-up
              0
              ·
              4 months ago

              It still works. is_this_thing_some_thingy. Is is just a prefix for if the suffix returns true/false.

  • Goodie@lemmy.world
    link
    fedilink
    arrow-up
    0
    ·
    4 months ago

    Whatever is more useful goes first.

    For example, if this we’re a list of UI text strings, finding all of the dialogue options together might be useful.

    If, instead, this is a series of variables already around one dialogue, then finding the open or close bits together would be useful.

  • Agent641@lemmy.world
    link
    fedilink
    arrow-up
    0
    ·
    4 months ago

    I just name my variables a, b, c etc. If I have more than 26 variables in any given function, I name them aa, ab, ac, etc.

  • jarfil@beehaw.org
    link
    fedilink
    arrow-up
    0
    ·
    edit-2
    4 months ago

    Both:

    dialog_error = Dialog_plain.create_modal(error_text)
    

    Variable and class names go from more general to more particular, functions begin with a verb.

    Global functions are either “main”, or start with one of “debug”, “todo”, or “shit”.

  • roon@lemmy.ml
    link
    fedilink
    English
    arrow-up
    0
    ·
    4 months ago

    Powershell has a lint warning for functions that don’t follow Verb-Noun format, and verbs here are a list of approved verbs lol

  • sparkle@lemm.ee
    link
    fedilink
    Cymraeg
    arrow-up
    0
    ·
    edit-2
    4 months ago

    in general, adjectives and verbs after nouns because it’s more organized/easier to search/filter. as god intended.

  • redcalcium@lemmy.institute
    link
    fedilink
    arrow-up
    0
    ·
    4 months ago

    I’m truly torn with this. The first one seems sensible (action -> target) and easier to read and reason about (especially with long names), while the other one looks more organized, naturally sortable and works great with any autocompletion system.

        • bitwolf@lemmy.one
          link
          fedilink
          arrow-up
          0
          ·
          edit-2
          4 months ago

          Also a programmer and think method names would be conducive using little endian.

          TopicGet()
          TopicCreate()
          TopicDelete()
          

          Writing this I realize we do this implicitly in some instances.

          http.Get() -> httpGet()
          http.Post() -> httpPost()
          
    • kunaltyagi@programming.dev
      link
      fedilink
      arrow-up
      0
      ·
      4 months ago

      We need a new framework, one that allows universal lookup, and makes life easier

      x = _.dialog.file.open
      y = _.open.file.dialog
      z = _.file.open.dialog
      a = _.file.dialog.open
      

      Once done, the formatter simply changes everything to _.open.file.dialog

      Let’s get this done JS peeps

      \s