My friends, please stop writing "something"s that do 1001 different things.
With regards,
Devs cleaning up old projectsYeah, that won’t happen.
And if you propose a separable set of functionality that you can mix as you like, you’ll get shut down on the base that it’s not viable (doesn’t matter if you had written it already), it’s too complex to understand (doesn’t matter that everybody keeps doing everything wrong because nobody can understand the current one) and YAGNI (doesn’t matter that keeping the current one running takes most of the time from everybody).
You see, that’s why you divide all the smaller distinct batches of logic into their own functions and then give the wrapper function a name like blahBlahOrchestrator or blahBlahManager waves hands mysteriously
I prefer to have a blahBlahManagerFactory, with an XML an incredibly brittle undocumented XML configuration file. /s
I find that it makes everyone’s work day simpler, because they simply cannot do their jobs. /s
If you don’t have your config in .txt files with incredibly confusing implicit syntax, you’re doing it wrong.
IAbstractBlahBlahManagerFactoryControlBeansHandlerFactoryFactory
I think you meant
IAbstractBlahBlahManagerFactoryControlBeansHandlerFactoryFactory6ProxyHandlerAsync_Compat3
, and of course its test counterpart,IAbstractBlahBlahManagerFactoryControlBeansHandlerFactoryFactory6ProxyHandlerAsync_Compat3::FakeMockVirtualDeviceTestManagerBeansFactory2_HACK_DO_NOT_USE
I wrote a bunch of
if
statements to work out how to handle various types of errors, and called it ErrorClassifier. Can I add “AI engineer” to my resume now?Only if you name it
ErrorClassifierGPT
It is with great pride that we present you with the Patriot Children initiative. It provides funding for schools to have fireworks shows on July 4th.
*^(It also extends the Patriot Act for 900 years, makes it legal for corporations to own slaves, and revokes the 4th amendment.)
There are 2 hard problems in computer science: cache invalidation, naming things, and off-by-1 errors
It really is.
I’ve learned a lot about language by coming up with names and seeing other people’s.
I think we are blessed with things like set/get. Such wonderful, simple, short concepts that compliment each other so well.
And they rhyme.
OP, I really hope you mean project names and not variable or function names
Nah, I’m gonna KISS
Keep it staggeringly substantial.
Yes. Keep it simple and stupid.
SRP all the way
If it does 1001 different things, naming it is the least of your problems.
I agree also organization of your code
When writing a small, throwaway project, I stick with theIP, theDir, theVar, etc. More fun that way. This is with shell scripts, btw. I’m sure compiled code would be far more of a mess far quicker doing this.
ETA: also someVar, someDir, etc